Registrarse
Resultados 1 al 16 de 16
  1. #1
    Tectron no ha iniciado sesión Acaba de empezar
    Ingreso
    15 sep, 08
    Ubicación
    Málaga
    Mensajes
    6
    Post Thanks / Like

    Fotos corruptas, rotas, deformadas, rayadas, corridas, incompletas...

    Buenas, este es mi primer post aqui, desde hace mucho tiempo tengo problemas con las fotos digitales que almaceno en los discos duros de mi PC, algunas se rompen y no se como solucionarlo si es que se puede, creo que ocurre al mover las carpetas con los jpg de un disco a otro o en el mismo disco, pero siempre al mover una gran cantidad de archivos jpg... Esto me lleva ocurriendo años ya y esporadicamente he buscado en foros de internet una solución, pero nunca lo logro.. xD os dejo unas fotos rotas de muestra para ver si me podeis ayudar, a mi me suena a que el problema no este en la cámara de fotos, me pasa incluso con fotos escaneadas. Los desperfectos son multiples, aqui solo dejo 2 fotos, pero son muchos los tipos de desperfectos, como dice el titulo.

    ¿Como puedo prevenir estos defectos? ¿Puedo arreglar los archivos dañados?

    Saludos y gracias.




  2. #2
    josealb no ha iniciado sesión Lleva poco por aquí
    Ingreso
    14 sep, 08
    Ubicación
    Barcelona
    Mensajes
    14
    Post Thanks / Like
    Es muy extraño como se te corrompen las fotos, lo normal sería que se quedaran completamente negras o negras a medias pero ese cambio de brillo me parece muy raro.

    En cualquier caso lo que yo haria seria tener copias de seguridad de las fotos, probar a copiar los archivos usando algun programa ke no sea el explorador de windows, xplorer por ejemlo, y prueba a pasar un test S.M.A.R.T. del disco duro a ver si está en buen estado

    Un saludo

  3. #3
    Tectron no ha iniciado sesión Acaba de empezar
    Ingreso
    15 sep, 08
    Ubicación
    Málaga
    Mensajes
    6
    Post Thanks / Like
    Gracias por responder josealb, bueno, el problema no creo que sea de este disco duro en concreto, ya que me pasa desde hace muchos años y las mismas fotos han estado en distintos discos al ir actualizando el PC, por ejemplo las primeras estaban en discos IDE ahora estan en discos SATA tanto las mas antiguas como las mas recientes, y casi en cada carpeta hay alguna foto con problemas..
    Una vez que saco las fotos de la tarjeta de memoria lo primero que hago es asegurarme que estan en buen estado, luego borro la tarjeta de memoria y luego si copio las carpetas con las fotos de un HDD a otro o dentro del mismo HDD reviso que esten todas en buen estado y sustituir las dañadas, eso me vale para prevenir fallos en las mas recientes, pero aun tengo muchas fotos dañadas de las cuales no tengo copias de seguridad (o que las copias de seguridad estan igualmente dañadas) y que me gustaría recuperar.
    Respecto a que no se queden negras... tengo de todo...

    Esta primera acaba de cambiar al modificarle el tamaño, en la original se ve esa franja de la foto junto a una negra algo mas grande, y ambas franjas se repiten varias veces.





    PD: A mi me da la impresión que es como si faltase un bit o un bit erroneo al archivo (o mas de uno) y eso provocase los desajustes en brillo, desplazamientos...
    Última edición por Tectron; 15/09/2008 a las 19:55

  4. #4
    josealb no ha iniciado sesión Lleva poco por aquí
    Ingreso
    14 sep, 08
    Ubicación
    Barcelona
    Mensajes
    14
    Post Thanks / Like
    Cita Iniciado por Tectron Ver mensaje
    PD: A mi me da la impresión que es como si faltase un bit o un bit erroneo al archivo (o mas de uno) y eso provocase los desajustes en brillo, desplazamientos...
    Lo cierto es que siendo un tipo de archivo comprimido, cualquier bit defecutoso puede estropear la imagen completa y no un solo pixel como podria pasar en bmp. Aun asi yo diria que son mas de un fallo los que crean esos desajustes en las imagenes. En cualquier caso es algo bastante extraño, has cambiado de SO? Yo probaría lo de copiarlo con otro programa como te dije antes o de comprobar el checksum de los archivos para saber si son o no completamente identicos (para ahorrarte el comprobarlas uno por uno)

    Respecto a lo de recuperar las antiguas, me temo que es un tema bastante dificil, esos errores seran dificiles de encontrar por algun algoritmo y aun encontrandolos las partes negras no seran recuperables.

    Lo unico que puedes hacer en mi opinion es solucionar el problema a partir de ahora.

    Un saludo y suerte

  5. #5
    Tectron no ha iniciado sesión Acaba de empezar
    Ingreso
    15 sep, 08
    Ubicación
    Málaga
    Mensajes
    6
    Post Thanks / Like
    De nuevo gracias por responder josealb, lo de pasarles un checksum es una gran idea! no habia caido en ello... me he bajado el xplorer y SO uso XP pero hace tiempo probe a visualizarlas con Mandrake y se veian exactamente igual. Lo que me parece muy raro es que parece que este problema solo lo tengo yo, cuando he cambiado todo el hardware varias veces en todos estos años y este problema sigue persiguiendome
    Para investigar un poco más voy a probar a abrir con un editor hexadecimal un jpg dañado y el mismo sin dañar, a ver que diferencias encuentro, y probar a cambiar un digito cada vez. Ya posteare como resulta el invento...

  6. #6
    Avatar de Kruger
    Kruger no ha iniciado sesión Gurú Ojodigitalero
    Ingreso
    20 oct, 04
    Ubicación
    Santa Cruz de Tenerife
    Mensajes
    8,877
    Post Thanks / Like
    Lo que te pasa es sumamente raro. Quiero suponer que cuando pasas las fotos al PC estas se ven perfectamente ¿no?; porque si de la cámara salen bien, al PC han de llegar bien también. Lo único que se me ocurre es que cada vez que abras la foto la estes guardando de nuevo en vez de simplemente cerrarla. Al ser JPG, cada vez que guardas de nuevo la imagen estás degradándola al ser un formato compresivo con pérdida. Si abrimos y guardamos varias veces la imagen llegará a degradarse de manera muy acusada. Otra cosa no se me ocurre. Ya nos contarás.

    Un saludo.
    Pentax K5 con sus cristalitos.
    Panasonic Lumix LX3.

  7. #7
    Avatar de Caiser
    Caiser no ha iniciado sesión Vivo en los foros
    Ingreso
    07 abr, 06
    Ubicación
    Tudela
    Mensajes
    3,106
    Post Thanks / Like
    Tienes un problema que a veces ocurre pero no con esa frecuencia, suele ser muy raro. Tendrás que buscar algo que sea común en todos los casos. Dices que el hardware no es ya que has cambiado varias veces de equipo y de SO, así que las otras opciones posibles son la cámara o las tarjetas de memoria. ¿Hay alguno de esos dos elementos que uses desde el principio?

    Puede que la cámara en ocasiones te deje los archivos abiertos y al copiarlos te den fallos o que tengas mal alguna tarjeta y te esté dando fallos aleatorios.

    Saludos

    Saludos
    Si tienes un ratillo y quieres aprender algo más, visita mi blog.

  8. #8
    Avatar de bobhandal
    bobhandal no ha iniciado sesión Habitual
    Ingreso
    29 jul, 04
    Ubicación
    San Pedro Sula, Honduras
    Mensajes
    700
    Post Thanks / Like
    lo mismo me paso a mi. Cambia el cable y solucion al problema.
    Me ha pasado dos veces.
    La primera era con el lecturador externo de la tarjeta SD y la segunda con un disco fijo externo. En ambos casos, se soluciono con cambiar el cable de comunicacion (USB ambos).
    Prueba eso.

  9. #9
    josealb no ha iniciado sesión Lleva poco por aquí
    Ingreso
    14 sep, 08
    Ubicación
    Barcelona
    Mensajes
    14
    Post Thanks / Like
    Cita Iniciado por Tectron Ver mensaje
    De nuevo gracias por responder josealb, lo de pasarles un checksum es una gran idea! no habia caido en ello... me he bajado el xplorer y SO uso XP pero hace tiempo probe a visualizarlas con Mandrake y se veian exactamente igual. Lo que me parece muy raro es que parece que este problema solo lo tengo yo, cuando he cambiado todo el hardware varias veces en todos estos años y este problema sigue persiguiendome
    Para investigar un poco más voy a probar a abrir con un editor hexadecimal un jpg dañado y el mismo sin dañar, a ver que diferencias encuentro, y probar a cambiar un digito cada vez. Ya posteare como resulta el invento...
    Otra cosa que se me ocurre es que sea culpa del explorer (me refiero al explorer.exe que gestioan el escritorio no a IE) que al acceder a los archivos para crear las miniaturas en la carpeta nueva te estropee los archivos, aunque seria reamente raro, probaria 2 cosas:

    1 marcar los archivos como de solo lectura
    2 configurar el explorer para ke no te muestre miniaturas de las imagenes

    cuando abras las fotos con el hex nos comentas que seguro que podremos darte mas informacion

    saludos!

  10. #10
    Tectron no ha iniciado sesión Acaba de empezar
    Ingreso
    15 sep, 08
    Ubicación
    Málaga
    Mensajes
    6
    Post Thanks / Like
    Bueno, probé a abrir una foto dañada y la misma sin dañar con un comparador de codigo hexadecimal y como era de esperar... no eran exactamente iguales, cambia el contenido de dos filas contiguas, esto ya lo he hecho a dos pares de fotos. Al copiar los tramos dañados y guardar los cambios la foto se arregla y se queda perfecta, pero esto no me sirve para nada ya que de las nuevas tengo copias de seguridad y de las antiguas no.



    Dejo una captura donde se ve el tramo dañado de una de las fotos (abajo) y el mismo tramo en buen estado (arriba) de la misma foto. Lo curioso es que en las que he comparado se repiten las mismas coincidencias:
    1º El tramo defectuoso es solo uno en todo el fichero.
    2º El tramo defectuoso esta formado en su mayoría por ceros.


    Kruger al pasarlas al PC se ven perfectamente, de la cámara no creo que sea ya que tengo incluso fotos escaneadas y de diferentes cámaras con estos mismos problemas. Tampoco creo que sea por abrirlas y guardarlas ya que lo normal es que solo las visualice con el ACDSee y rara vez edite alguna con Paint Shop Pro.

    Caiser lo mismo que a Kruger, son distintas cámaras, tarjetas y hardware en el PC. No creo que sea muy relevante pero no recuerdo este tipo de fallos antes de tener la cámara que más suelo utilizar, la Canon PowerShot Pro 90 IS, claro que esta camara es bastante antigua y que no solo les pasa a las fotos capturadas por esta.

    josealb yo tambien creo que por ahi van los tiros, culpa del explorer, yo suelo usar contraseña en windows, antes de formatear la quito, formateo, me vuelvo a hacer propietario de todos los archivos, y vuelvo a poner una contraseña.
    En todos los archivos dañados las miniaturas se ven sin defectos, pero no tengo muy claro como windows crea las miniaturas, pero doy por supuesto que el jpg "solo lo lee".
    Otra cosa que barajo es que las halla roto yo siempre haciendo el bestia... pasando carpetas demasiado cargadas, copiar 2 carpetas distintas a la vez, copiar con el uso de la CPU a tope....

  11. #11
    esparraguero2009 no ha iniciado sesión No ha empezado
    Ingreso
    25 abr, 11
    Ubicación
    MADRID
    Mensajes
    2
    Post Thanks / Like
    Hola Tectron
    Recientemente me ha salido a mi el problema (en marzo de 2011).
    He probado con la cámara en otros PC y los ficheros se ven bien.
    Lo último que he hecho ha sido formatear el disco duro (un windows vista ) y después del follón, sigue igual.
    ¿encontraste una solución?

  12. #12
    Avatar de Jaco
    Jaco no ha iniciado sesión Vivo en los foros
    Ingreso
    26 mar, 09
    Ubicación
    San Fernando (CADIZ)
    Mensajes
    2,222
    Post Thanks / Like
    El problema que creo que tú tienes es con el disco duro, que se está degradando y estás perdiendo información de clusters que no están marcados como malos para que no se sigan usando. Pásale un buen programa de checkeo de discos duro, pero lo mejor sería cambiarlo.

    Saludos,
    Última edición por Jaco; 26/04/2011 a las 18:01
    Nikon D700, Nikon D90, Nikon AF-S 14-24 f2.8G ED, Nikon AF-S 24-70 f2.8G ED, Nikon AF-S 70-200 f2.8G ED VRII, Nikon 35 f2D, Nikon 50 f1.8D, Nikon Speedlight SB-900, Sigma 105mm f2.8 DG EX Macro, Sigma 135-400mm f4.5-5.6 APO DG, Manfrotto 190XPROB + 486RC2, Manfrotto 681B + 494RC2.

  13. #13
    Avatar de John Connor
    John Connor no ha iniciado sesión Lleva poco por aquí
    Ingreso
    04 abr, 10
    Ubicación
    Caprica City
    Mensajes
    107
    Post Thanks / Like
    Cita Iniciado por Tectron Ver mensaje
    yo suelo usar contraseña en windows, antes de formatear la quito, formateo, me vuelvo a hacer propietario de todos los archivos, y vuelvo a poner una contraseña.


    Otra cosa que barajo es que las halla roto yo siempre haciendo el bestia... pasando carpetas demasiado cargadas, copiar 2 carpetas distintas a la vez, copiar con el uso de la CPU a tope....
    Por aquí van los tiros. Por ambas cosas puede pasar, sobre todo por lo primero. A mi me ha pasado algo parecido con videos. Solución: ponerlos en una partición distinta, sin permisos ni leches.
    Por copiar varias algo sin que acabe de copiar lo anterior tambien puede pasar, sobre todo si lo haces de manera habitual. Y lo mas normal es que te cargues el formato del disco. Sobre todo si esta en FAT32

  14. #14
    esparraguero2009 no ha iniciado sesión No ha empezado
    Ingreso
    25 abr, 11
    Ubicación
    MADRID
    Mensajes
    2
    Post Thanks / Like
    Gracias Jaco
    A mi también me huele a eso, voy a intentarlo con otro programa, porque le pase el TuneUp y el HD Tune Pro y no salió nada.
    También lo formatee.
    Probaré otro software de supervisión y si no probaré a cambiar

  15. #15
    jlestrada no ha iniciado sesión Lleva poco por aquí
    Ingreso
    01 may, 11
    Ubicación
    Sevilla
    Mensajes
    14
    Post Thanks / Like
    Si has cambiado de discos duros, incluido el que contiene el Sistema operativo. Lo mas probable es que tengas un poblema con la RAM. Aunque mtambien podria ser del procesador pero seria mas raro.
    Última edición por jlestrada; 04/05/2011 a las 18:51 Razón: Errata

  16. #16
    Tectron no ha iniciado sesión Acaba de empezar
    Ingreso
    15 sep, 08
    Ubicación
    Málaga
    Mensajes
    6
    Post Thanks / Like
    Hola de nuevo, solo comentar que ya no tengo esos problemas de archivos corruptos con las nuevas fotos, ahora siempre tengo copia de seguridad y las nuevas fotos no se me "corrompen". Las antiguas no he podido salvarlas, una pena.

    Saludos


 

Permisos de publicación

  • No puedes crear nuevos temas
  • No puedes responder temas
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •